wordpress   /   160

不论我们是在自己的Linux VPS主机中安装的LNMP还是LLSMP这些一键安装包环境,在搭建或者搬家进来Wordpress程序架构的网站,我们如果需要在网站后台升级、安全主题或者插件的时候,是不是都会提示需要我们提供FTP信息的界面。有这样的字样提示”要执行请求的操作,WordPress需要访问您网页服务器的权限。请输入您的FTP登陆凭据以继续。
wordpress-ftp
第一:

chown -R www /home/wwwroot/laozuo.org(修改成网站域名目录)

第二:或者可以使用在wp-config.php文件中添加脚本方式。

define(“FS_METHOD”,”direct”);
define(“FS_CHMOD_DIR”, 0777);
define(“FS_CHMOD_FILE”, 0777);

上述脚本添加到文件最后面就可以。

以上2个方法都可以解决这个问题,我们可以选择自己喜欢的解决VPS升级/安装WordPress主题及插件需要输入FTP问题。

网络发现者(aiwei.us)是梁道科技旗下以企业建站,微信开发,视觉设计为主要服务项目的互联网品牌。

我们为企业提供各类互联网平台项目的咨询顾问服务。依靠丰富的互联网实践经验,我们为企业从项目可行性分析,执行策略及方案等方方面面提供合理化建议。